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Disclaimer

The information written in this document is assumed to be accurate without guarantee. The
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without notice. SEGGER Microcontroller GmbH (SEGGER) assumes no responsibility for any errors
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Copyright notice
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license and may only be used or copied in accordance with the terms of such a license.
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Manual versions

This manual describes U-Flash, formerly known as Universal Flash Loader Configurator.

Print date: February 5, 2025

Manual
version

Revision Date By Description

8.12e 0 250205 JC Removed obsolete 3rd party references

8.10 0 241206 AW Complete overhaul of all chapters

7.88 0 230718 MM Added description for Universal Flash Loader’s command-line options.

U-Flash User Guide (UM08037) © 2019-2024 SEGGER Microcontroller GmbH



4

U-Flash User Guide (UM08037) © 2019-2024 SEGGER Microcontroller GmbH



5

Table of contents

1 Introduction ....................................................................................................................7

1.1 What is U-Flash? ........................................................................................... 8
1.1.1 Features ............................................................................................ 8
1.1.2 Supported Cores / Devices ...................................................................8

2 U-Flash ..........................................................................................................................9

2.1 Overview .....................................................................................................10
2.2 Creating a new U-Flash project ......................................................................11

2.2.1 Startup ............................................................................................ 11
2.2.2 Selecting a device .............................................................................11
2.2.3 Adding a data file ............................................................................. 16
2.2.4 Configuring common project options ....................................................18

2.2.4.1 U-Flash settings ..................................................................... 18
2.2.4.2 Flasher Settings ..................................................................... 19
2.2.4.3 Tasks .................................................................................... 19
2.2.4.4 Target power supply control .................................................... 19
2.2.4.5 Generate and program serial numbers ...................................... 19

2.2.5 Configuring device-specific options ...................................................... 20
2.2.6 Saving the U-Flash project ................................................................. 21
2.2.7 Saving a U-Flash project as a template ................................................21
2.2.8 Selecting a Flasher unit ..................................................................... 21
2.2.9 Downloading files to the Flasher ......................................................... 22
2.2.10 Programming the target device via U-Flash .........................................22

2.3 Creating a U-Flash batch project ....................................................................24
2.4 Opening an existing U-Flash project ............................................................... 26
2.5 Saving the project-related configuration and data files ......................................27
2.6 Generating test data files ..............................................................................28

2.6.1 Generating a test data file for writing .................................................. 28
2.6.2 Generating a test data file for read ..................................................... 28

2.7 Reading back data from a device ................................................................... 30
2.7.1 Reading from a device to the console (Action > Read) ........................... 30
2.7.2 Reading from a device to a file (Action > Read to file) ........................... 30

2.8 Serial Number programming ..........................................................................31
2.9 Command line options .................................................................................. 32
2.10 Creating a support package .........................................................................34

3 Generating secure target binary packages for Flasher Secure .................................. 35

3.1 Introduction .................................................................................................36
3.2 Adding TELPs to U-Flash ............................................................................... 37

U-Flash User Guide (UM08037) © 2019-2024 SEGGER Microcontroller GmbH



6

3.3 Creating a secure target binary packages for Flasher Secure ..............................38

4 Literature and references ............................................................................................40

U-Flash User Guide (UM08037) © 2019-2024 SEGGER Microcontroller GmbH



Chapter 1
 
Introduction

This chapter provides a short overview about U-Flash and its features.
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1.1    What is U-Flash?
U-Flash (formerly known as the Universal Flash Loader Configurator) is a software utility
to prepare SEGGER Flasher units for stand-alone programming of more than 20,000 pro-
grammable devices via a variety of target interfaces. It includes a device database and an
intuitive user interface for configuration.

The configuration and data files required for programming can be directly downloaded via
USB to a connected SEGGER Flasher unit. U-Flash allows to save the configuration settings
into a project file for later use, so the image file can easily be updated if needed.

It is also possible to trigger programming cycles directly from within U-Flash.

U-Flash is also used to create secure target binary packages for the SEGGER Flasher Secure
programming solution.

1.1.1    Features
U-Flash supports the following features:
• Erase a device,
• Program a device,
• Verify a device,
• Read a device,
• Secure a device,
• Configure a device,
• Configure the target interface.

Please note that not all features are available for all devices.

1.1.2    Supported Cores / Devices
To see a list of devices supported by SEGGER Flasher programmers, please visit
https://www.segger.com/supported-devices/flasher/.

If a device is listed as supported on the a.m. web page, but you can’t find it in U-Flash,
please check if the device is supported in the SEGGER J-Flash programming utility instead.
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U-Flash
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2.1    Overview
U-Flash is the software tool for setting up the project files needed for programming devices
supported by the SEGGER Flasher family of production programmers, using the SEGGER
Universal Flasher Loader technology.
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2.2    Creating a new U-Flash project

2.2.1    Startup
When you start U-Flash, you will see the following startup screen for starting a new (single)
U-Flash project:

Note: The default U-Flash project type is a single project. For information on how to create
a batch project in U-Flash, please see the respective section further down in this document.

2.2.2    Selecting a device
To select the target device to be programmed, choose the menu item Configure > Select
Device, or click the Select device button.
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This opens the device selection dialog, which lists all currently supported devices sorted
by device name.
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By clicking on the blue column headers, you can also sort the device list by vendor, core,
or device family.

You can narrow down the list by selecting a specific vendor from the pull-down menu or by
entering the device name into the corresponding field.
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After you selected your device, you can choose one of the available target interfaces for
the device from the interface pull-down menu.

Then click OK.

If you selected a target interface other than one of the common debug interfaces, clicking
on the Show wiring button brings up the wiring diagram required to program the device.
(Otherwise, this button is grayed out.)
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Clicking on the Device info tab provides you with flash-programming related information
about the selected target device.
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2.2.3    Adding a data file
The next step is to add a data file (*.dat, *.elf, *.bin, *.hex, *.mot, *.s, *.s19, or *.srec) to
your project. You can add the data file by selecting File > Open Data File from the menu
and browsing to the data file. You can also click the Select data file button.

If you selected a binary (*.bin) file, the start address offset can be specified in the corre-
sponding field to the right.
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2.2.4    Configuring common project options
Project settings can be configred in the Configure > Project Settings dialog, or by clicking
the Configure project button. The project settings may vary depending on the selected
device. You can choose between the Basic view (default) and the Extended view via
the pull-down menu on the bottom left hand corner. The image below shows an example
of the project settings dialog in extended view, highlighting the common project options
on the left.

The available common project settings are:
• U-Flash settings,
• Flasher settings,
• Tasks,
• Target power supply control, and
• Generate and program serial numbers.

Each option will be discussed in more detail below.

2.2.4.1    U-Flash settings
The U-Flash settings allow you to control the following properties:
• Configuration project name: This field specifies the name used in the Flasher’s

file system for the configuration file. The default name is either “FLASHER.UNI” or
“FLASHER.CFG”, depending on which device has been selected. The “.UNI” / “.CFG”
extension will be added automatically. Note: Only the 8.3 file name format is supported,
unless the “Use longer file names” option is checked (see below).
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• Project display text: This field specifies an alternate project name as it will be
displayed on the Flasher Portable Plus model. This setting has no effect for all other
Flasher models (without display).

• Save serial number in project file: This option can be enabled to include the serial
number of the selected Flasher unit in the U-Flash project file when it is saved. In this
case, the same Flasher unit automatically gets selected again when opening the U-Flash
project.

• Add project to FLASHER.INI: Creates or updates an entry for this project in the
FLASHER.INI initialization file to automatically select this project for invocation with the
#auto command or to include it in the selection list for the Flasher Portable Plus model.

• Use longer file names: This option enables the support of file names with a maximum
length of 31 characters (including the file extension). If unchecked, file names are
automatically shorthened to fit the 8.3 scheme.

• Skip blank data: Enable this option to prevent the creation of data areas for empty
sectors in the .DAT file. Caution: Do not use this option with Infineon Aurix (TC2xx) or
Aurix-2 (TC3xx) devices.

2.2.4.2    Flasher Settings
• Overwrite FLASHER.INI settings: Creates or updates the [CONFIG] section of the

FLASHER.INI initialization file with the selected values below.
• ShowDatCRCAfterProgramming: Activates displaying the data file CRC after

programming.

2.2.4.3    Tasks
The Tasks settings define which tasks will be executed during a programming cycle, started
e.g. by sending the #auto command to the Flasher, or by pressing the PROG button.
• Erase method: This setting adds the “Erase” task when invoking the auto command

and selects the erase method (e.g. bulk erase, erase non-empty sectors, erase required
sectors, etc.)

• Program: This setting adds the “Program” task when invoking the auto command.
• Verify: This setting adds the “Verify” task when invoking the auto command.
• Secure: This setting adds the “Secure” task when invoking the auto command in order

to perform security measures after programming.

For most devices, the “Erase”, “Program”, and “Verify” tasks are selected by default. How-
ever, the default selection may vary depending on the selected device.

2.2.4.4    Target power supply control
• Output VSupply on pin #19: If activated, the Flasher will turn on the target power

supply on pin #19 of the Flasher’s 20-pin connector during the programming cycle.
When powered via USB, the output voltage is ~5V. Note: On Flasher Portable Plus V5
models, the output voltage varies between ~3.5V and ~4.2V, depending on the charge
level of the internal battery.

• Delay until programming: If the option above is selected, this setting allows to add
a 20ms to 3000ms delay between turning on the target power supply and starting a
programming cycle.

• Manually set signal I/O level: Activate this option to set the nominal HIGH level of
the I/O signal pins independently of the voltage at the VTref pin (pin #1) and therefore
disable automatic voltage detection. This may be necessary if VTref is not available or
a value other than indicated by VTref is required.

• Signal I/O level: If the setting above is activated, the entered value is used to set
the HIGH level of the signal I/O pins.

2.2.4.5    Generate and program serial numbers
If this setting is activated, various selections can be made to specify the serial numbers
that shall be programmed into the target memory during programming cycles.
• Address: Memory address to which the generated serial number will be written during

programming

U-Flash User Guide (UM08037) © 2019-2024 SEGGER Microcontroller GmbH



20 CHAPTER 2 Creating a new U-Flash project

• Increment: Increment from one generated serial number to the next
• Length: Defines the length (in bytes) allocated to the generated serial numbers
• Next serial number: Value of the next serial number to be generated

Note: On most Microchip PIC devices, the programming of serial numbers using this setting
is only possible to a certain extent due to the limited 12-bit / 14-bit opcode size. We rec-
ommend to use the Patch file support feature to program serial numbers into these devices
(please see Flasher User Guide (UM08022) for details.

2.2.5    Configuring device-specific options
Most devices and projects require some device-specific configurations. These configurations
can be made on the right side of the project settings dialog.

Because there are so many device-specific options, it is not practical to attempt to cover
them all in this manual. Plus, new devices with device-specific options are added frequently.
When presented with these options, please use the tool tips in the device settings dialog
to get details on these options.

Note: One important setting in the device-specific options worth mentioning here is the
VerboseOutput setting that is supported for more and more devices in U-Flash. The Ver-
boseOutput setting controls the amount of information that is being output by the Flasher
unit during the programming process. The default verbosity level is none, but for trou-
bleshooting purposes, the verbosity level can be increased to other options, e.g. info, de-
bug, etc. The available verbosity levels are device-specific.
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2.2.6    Saving the U-Flash project
A new U-Flash project can be saved by selecting File > Save project as from the menu.
The resulting project file has the extension .uflash. If you have already saved the project
once, you can save the most recent changes with the menu item File > Save project.

2.2.7    Saving a U-Flash project as a template
A U-Flash project can be saved as a template by selecting File > Save project as template
from the menu. After you save a U-Flash project as a template, you will then be able to
select this template project in the device selection dialog from the Templates tab (instead
of selecting a device only).

All settings and options in U-Flash will then be populated with the values from the loaded
template. This allows to load a certain U-Flash project configuration without having to touch
the original U-Flash project.

2.2.8    Selecting a Flasher unit
To select the Flasher unit to be used for programming, choose the menu item Configure >
Select Flasher, or click the Select Flasher button. This opens the Flasher selection dialog.

You can choose to have all discovered Flashers displayed, or just the ones that are connected
via USB, or just the ones connected via TCP/IP by selecting the corresponding tab.
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You can also manually add a Flasher unit to the list by providing its serial number or TCP/
IP address.

By clicking on Deploy current firmware, the firmware of the selected Flasher unit(s) can
be updated to the latest version available in the version of U-Flash used.

Note that one instance of U-Flash can only be connected to one specific Flasher unit at
any given time. However, it is possible to select multiple Flashers to perform a firmware
update. The selected Flashers will be updated sequentially when clicking the Deploy cur-
rent firmware button.

2.2.9    Downloading files to the Flasher
After a Flasher unit has been selected, the project files can be downloaded to the Flasher
by choosing the menu item Action > Download configuration, or by clicking the Send
to Flasher button.

After the project files have been downloaded to the Flasher, you can start a programming
cycle by sending the #auto command to the Flasher, or by simply pushing the PROG button
on the Flasher unit.

2.2.10    Programming the target device via U-Flash
You also have the option to start a programming cycle from within U-Flash.

You can do so by typing the #auto command into the command line field below the console
and confirming with the Enter key.
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Another way to start a programming cycle from within U-Flash is to select the Remote
Control tab and click on AUTO.
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2.3    Creating a U-Flash batch project
U-Flash also offers the possibility to create a batch project. After starting U-Flash or after
selecting File > New project, you can click the Batch project tab to open the batch
composer window.

This allows you combine several separate U-Flash projects and download them as a batch
project to the Flasher unit to be executed sequentially. You can add existing (single) U-
Flash projects to the batch project, as well as create new projects to be added.

When creating a new U-Flash project from within the batch composer window, a new U-Flash
instance is launched in batch composer mode. You can then configure the project, select a
data file, etc. as you would for a single U-Flash project. Make sure that the Configuration
project name in the U-Flash settings is unique. After you’re done, save the U-Flash project
and close / exit the associated U-Flash instance. The newly created single U-Flash project
will automatically be added to the batch project in the main U-Flash instance.

Clicking on Send batch to Flasher downloads the batch project to the connected Flasher.
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Clicking on Save project saves the batch project to disk in “.uflash” format for later use.
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2.4    Opening an existing U-Flash project
If you would like to open a previously saved U-Flash project (*.uflash), you can do so by
selecting File > Open project from the menu.

Both single and batch U-Flash projects can be opened this way.
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2.5    Saving the project-related configuration and data
files

The generated configuration and data file for a U-Flash project can be saved to a hard
drive, e.g. to store them in a version control system. Selecting File > Save Flasher UNI
file saves the project configuration file. Selecting File > Save Flasher DAT file saves the
project data file.

Overall, you will get:
• <my_conf>.CFG or <my_conf>.UNI, depending on the device (contains the project

setup),
• <my_data>.DAT (contains the project data to be programmed into the device’s

memory),
• a *.pex and/or *.bin file with a device-specific flash loader (optional, depending on the

device).
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2.6    Generating test data files
U-Flash allows the generation of test data files.

2.6.1    Generating a test data file for writing
The menu item File > Generate test data file offers the option to generate a data file
for writing to the selected chip for testing purposes.

This option can be used to try out a programming cycle on a certain device if no “real” data
file is available (yet). The user has the option to select the Flash banks to generate test
data for. The generated *.MOT file contains random data and can be saved to disk by the
user. U-Flash console output:

Test data file saved to: C:/…/my_test_data_file.MOT

The newly generated file then also becomes the active data file in the U-Flash project so it
can be downloaded to the selected Flasher. U-Flash console output:

New Data File selected: C:/…/my_test_data_file.MOT

Please note that certain flash banks on the selected device are not presented to the user
as options for test data generation. Examples for this are flash banks that hold device
configuration data, or areas that contain OTP memory. If random data were to be written
to these areas, the device might be rendered locked or otherwise unusable after a test
programming cycle.

Please also note that this feature is not implemented for every device.

2.6.2    Generating a test data file for read
The menu item File > Generate data file for read offers the option to generate a data
file that simulates the reading of the selected chip for testing purposes.
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This option can be used to simulate a read cycle on the selected device. The user has the
option to select the Flash banks to generate test data for. The generated *.MOT file contains
the default values that would be found on a blank device and can be saved to disk by the
user. U-Flash console output:

Test data file saved to: C:/…/my_read_test_data_file.MOT

The newly generated file then also becomes the active data file in the U-Flash project so it
can be downloaded to the connected Flasher. U-Flash console output:

New Data File selected: C:/…/my_read_test_data_file.MOT

Please note that for read test data generation, all flash banks that are available on the
selected device are presented to the user as options. But because all memory areas contains
the default values that would be found on a blank device, no memory areas are changed in
case of accidentally writing this test data file to the device, e.g. by sending an unintended
auto command or by accidentally pressing the PROG button on the Flasher.

Please note that this feature is not implemented for every device.
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2.7    Reading back data from a device

2.7.1    Reading from a device to the console (Action > Read)
The menu item Action > Read allows reading back the memory contents of a device and
displaying it in the U-Flash console in Motorola S3 format.

Please note that this feature is not implemented on all devices.

2.7.2    Reading from a device to a file (Action > Read to file)
The menu item Action > Read to file allows reading back the memory contents of a device
and storing it in a .MOT file.

Please note that this feature is not implemented on all devices.
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2.8    Serial Number programming
U-Flash can be configured to have the Flasher unit program simple individual serial numbers
into the devices. This option can be configured in the corresponding fields in the project
settings dialog.

The corresponding options are:
• Generate and program serial numbers,
• Address,
• Increment,
• Length, and
• Next serial number.

Generate and program serial numbers

This checkbox activates or deactivates the serial number programming option.

Address

The address field defines the memory address in the devices where the serial number will
be stored.

Increment

The increment defines the value to be added to the current serial number to generate the
next serial number after a successful programming cycle.

Length

The length defines how many bytes (1, 2, or 4) the generated serial numbers shall have.

Next serial number

This values defines the serial number to be programmed into the next device. If it is the
first device, you could also call this the starting serial number.

Note: On most Microchip PIC devices, the programming of serial numbers using this setting
is only possible to a certain extent due to the limited 12-bit / 14-bit opcode size. We rec-
ommend to use the Patch file support feature to program serial numbers into these devices
(please see Flasher User Guide (UM08022) for details).
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2.9    Command line options
U-Flash can be controlled via a command line interface (CLI), e.g. from within scripts, in
order to automate the download of projects onto a Flasher that is connected via USB to
the host computer.

This chapter lists and describes all available command line options. Some options accept
additional parameters which are enclosed in angle brackets, e.g. <FILENAME>. If these
parameters are optional, they are also enclosed in square brackets, e.g. [<SADDR>].
Neither the angle brackets nor the square brackets must be typed on the command line.
They are used only to denote (optional) parameters.

It is recommended to always use

-openprj<PRJFILENAME> -opendat<FILENAME>[,<SADDR>]

to make sure the correct project and data files are opened.

All command line options return 0 if the processing was successful. A return value other
than 0 means that an error occurred.

Option Description

Project:
-openprj <FILEPATH> Opens an existing project
-device <DEVICENAME>,<INTER-
FACE>

Creates a new project and selects the device
with the selected target interface.

-saveprj Saves the currently open project

-saveprjas <FILEPATH> Saves the currently open project to the select-
ed file path

Data file:

-opendat <FILEPATH>[,<SADDR>]
Opens an existing data file and sets the offset
for .bin files. Supported file types: *.dat, *.elf,
*.bin, *.hex, *.mot, *.s, *.s19, *.srec

-savedat <DIRECTORY> Saves the currently open data file to the given
directory as a SEGGER .dat file.

Configuration file:

-savecfg <FILEPATH>
Saves the configuration of the currently open
project as SEGGER .uni or .cfg file depending
on the selected device to the selected file path

Flasher:
-sn <SERIALNUMBER>:<MODU-
LENUMBER1,…>

Connects to the Flasher with the selected serial
number

-download
Downloads the currently open project to the
selected Flasher. The Flasher has to be select-
ed with -sn first.

Programming *:

-erase Erases the target device with the erase method
selected in the project settings

-program Programs the target device with the selected
data file

-verify Verifies the target device’s memory with the
selected data file

-read Reads back the sectors defined in the selected
data file from the target device
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Option Description

-auto Executes the tasks selected in the project set-
tings

Help:
-h
-help
--help

Displays the available commands

Miscellaneous:

-exit Prevents showing the GUI and terminates the
application automatically

*: A Flasher has to be selected with the -sn option and the correct project must be select-
ed/downloaded before using these options. Only one of these commands can be used at
a time.
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2.10    Creating a support package
U-Flash provides the option to create a support package that can be attached to a SEG-
GER tech support ticket. The support package includes everything required by SEGGER’s
engineering staff to do an analysis of a support case involving U-Flash. In order to gener-
ate a support package, go to Help > Create support package. Please note that, for the
protection of your IP, all custom data in the data file is being replaced with 0xFF. In most
cases, this will still allow analysis and resolution of a submitted support ticket.
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3.1    Introduction
Flasher Secure is a high-volume production programming system from SEGGER, capable
of protecting a company’s IP regardless of the production site. It provides full control over
the programming process at CMs and similar environments. For more information about
Flasher Secure, please visit
https://www.segger.com/products/production/flasher/models/flasher-secure/.

As part of the Flasher Secure system, secure target binary packages (which include the
device-specific Target Encryption Link Package (TELP)) need to be created using U-Flash.
This chapter describes this process.
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3.2    Adding TELPs to U-Flash
As a TELP is a commercial product requiring its own license, U-Flash (which is a free utility)
does not include any TELPs by default. Therefore, after a device-specific TELP has been
purchased and received, it needs to be added to U-Flash. Before doing so, please download
the latest Flasher Software and Documentation Pack from the SEGGER website and install
it (https://www.segger.com/downloads/flasher).

TELPs are delivered in a zip archive containing an xml file and a directory containing all
other data. To install the TELP, the content of the zip archive needs to be copied to the
UFlashDevices directory:

OS Location

Windows C:\Users\<USER>\AppData\Roaming\SEGGER\UFlashDevices
Linux $HOME/.config/SEGGER/UFlashDevices
macOS $HOME/Library/Application Support/SEGGER/UFlashDevices

On Windows, the installed TELP for the PIC32CX2051MTC128 device would look like this:

To verify correct installation, open U-Flash, click “select device”, and search for the device
name you just installed the TELP for. After you select the device, “SBL” (SEGGER Secure
Boot Loader) will be shown in the interface selector.

The process is the same when adding more TELPs for other devices. Just copy the additional
xml files and folders to the UFlashDevices directory.

Note: This process applies to TELPs delivered after December 2024. Older TELPs had to be
installed into the Flasher SW Pack installation directory.
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3.3    Creating a secure target binary packages for
Flasher Secure

Once you have installed the TELP, you’ll be able to create a U-Flash project based on the
device that uses “SBL” as the interface. Open U-Flash, click “select device”, and search for
a device for which a TELP has been installed. After you select the device, “SBL” (SEGGER
Secure Boot Loader) will be shown in the interface selector.

In the Device Settings dialog, you will see some additional options to configure the SBL and
its communication with the Flasher Secure programmer.

Please click on the question marks in the settings dialog for additional information about
each setting.

You can now add your data file as usual. Then save the U-Flash project. The secure target
binary package (a non-compressed .zip file) will be created in the process (in the same
directory as the U-Flash project). This is the secure target binary package that you can
then upload to one of your projects in the Flasher Secure Server. For more information on
this, please refer to the Flasher Secure User Guide (available on request).

Content of an example package:
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Chapter 4
 
Literature and references

This chapter lists documents that may be useful to gain a deeper understanding of technical
details.

Title Comments

Flasher User
Guide

This online document describes the SEGGER Flasher programmers. It
is available at
https://wiki.segger.com/UM08022_Flasher.

J-Flash User
Guide

This document describes the SEGGER J-Flash utility. It is available at
https://www.segger.com/downloads/flasher/UM08003.
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